博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
hdu 1875 hdoj 1875
阅读量:4122 次
发布时间:2019-05-25

本文共 1901 字,大约阅读时间需要 6 分钟。

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5382    Accepted Submission(s): 1595
Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 
Sample Input
2210 1020 2031 12 21000 1000
 
Sample Output
1414.2oh!

#include<stdio.h>

#include<stdlib.h>
#include<math.h>
int father[103];
typedef struct Island{
    int x;
    int y;
    double cost;
}Island;
int compare(const void *a,const void *b){
    if((*(Island*)a).cost>(*(Island*)b).cost) return 1;
    else if((*(Island*)a).cost<(*(Island*)b).cost) return -1;
    else return 0;
}
Island land[5051];
int find(int x){
    if(x!=father[x]){
        find(father[x]);
    }
    else return x;
}
void unionset(int x,int y){
    int a=find(x),b=find(y);
    if(a<b) father[b]=a;
    else father[a]=b;
}
int main(){
    int t,c,i,num,count,j;
    double cost;
    int maze[103][2];
    scanf("%d",&t);
    while(t--){
        for(i=0;i<103;i++){
            father[i]=i;
        }
        count=0,cost=0,num=0;
        scanf("%d",&c);
        for(i=0;i<c;i++){
            scanf("%d%d",&maze[i][0],&maze[i][1]);
        }
        for(i=0;i<c;i++){
            for(j=i+1;j<c;j++){
                double dist=sqrt(1.0*(maze[i][0]-maze[j][0])*(maze[i][0]-maze[j][0])+(maze[i][1]-maze[j][1])*(maze[i][1]-maze[j][1]));
                if(dist>=10&&dist<=1000){
                    land[num].x=i;
                    land[num].y=j;
                    land[num].cost=dist;
                    num++;
                }
            }
        }
        if(num<c-1){
            printf("oh!\n");
            continue;
        }
        qsort(land,num,sizeof(Island),compare);
        for(i=0;i<num;i++){
            if(find(land[i].x)!=find(land[i].y)){
                unionset(land[i].x,land[i].y);
                cost+=land[i].cost;
                count++;
            }
            if(count==c-1) break;
        }
        if(count==c-1) printf("%.1lf\n",cost*100);
        else printf("oh!\n");
    }
    return 0;
}

转载地址:http://uxtpi.baihongyu.com/

你可能感兴趣的文章
vue 遍历对象并动态绑定在下拉列表中
查看>>
Vue动态生成el-checkbox点击无法选中的解决方法
查看>>
python __future__
查看>>
MySQL Tricks1
查看>>
python 变量作用域问题(经典坑)
查看>>
pytorch
查看>>
pytorch(二)
查看>>
pytorch(三)
查看>>
pytorch(四)
查看>>
pytorch(5)
查看>>
ubuntu相关
查看>>
C++ 调用json
查看>>
nano中设置脚本开机自启动
查看>>
动态库调动态库
查看>>
Kubernetes集群搭建之CNI-Flanneld部署篇
查看>>
k8s web终端连接工具
查看>>
手绘VS码绘(一):静态图绘制(码绘使用P5.js)
查看>>
手绘VS码绘(二):动态图绘制(码绘使用Processing)
查看>>
基于P5.js的“绘画系统”
查看>>
《达芬奇的人生密码》观后感
查看>>